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Tutorials

The lessons in this tutorial give you the chance to learn Toon Boom Studio 
using realistic examples. 

You can do these lessons in any order. Each are self-contained so that you can 
learn about the features that interest you most.

The material for these lessons is included in the Tutorials folder in the Toon 
Boom Studio application folder on your computer.

This chapter includes the following lessons:

• Lesson 1: Drawing on page 4

• Lesson 2: Painting on page 13

• Lesson 3: Lip Syncing on page 24

• Lesson 4: Building a Multiplane Scene on page 32

• Lesson 5: Creating Cross-Dissolves with Color Transform Elements on 
page 43

• Lesson 6: Creating Clipping Mask Effects on page 53

• Lesson 7: Retouching Drawings in Sceneplanning on page 58
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Lesson 1: Drawing
In this lesson, you will work with Toon Boom Studio drawing tools to create frame-by-
frame animation. 

There are two animation projects for this lesson:

• Drawing_Rough
• Drawing_Final

You’ll use the Drawing_Rough animation project to complete a walk cycle. You’ll use 
the onion skin, rotary light table, and the Toon Boom Studio centerline drawing tools 
and pressure-sensitive Brush tool to draw Mike Ant.

To start the Drawing Mike Ant lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Drawing_Rough animation project in the Lesson1_Drawing folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original 
to return to and use should you want to.

You’ll draw this ant so it fits 
between the previous and 
next frames.

Previous frame. Next frame.

Current frame.
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Step 1: Draw Mike Ant’s Body
In this step, you will draw the body of Mike Ant using the Ellipse tool. Because this 
drawing must fit with the other drawings in the element to create a complete cycle, you 
will use the onion skin to show previous and next drawings of an element as a 
reference while you draw.

To draw Mike Ant’s body:

1. In the Exposure Sheet window, click the first cell in the rough-mike element and 
press the down arrow key on your keyboard. As you cycle through all of the 
drawings in the rough-mike element, you’ll notice that there is no drawing in the 
rough-mike-2 cell. That’s because you are going to draw it!

2. Click the Drawing View window and set it up so that you have a clear view of 
Mike Ant.
• To turn on and off the grid, press [G], the default keyboard shortcut.
• To zoom in, press [X], and to zoom out press [Z].
• To pan the Drawing View window, press and hold [Spacebar] and use the 

Grabber tool to change the part of the window you are seeing.

3. Select the rough-mike-2 cell. 
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4. In the toolbar, click the Onion Skin button to turn on the onion skin feature. 
When the onion skin is active, the button looks like it is pressed in.

 

5. Click the Show Previous  button and select Previous Drawing and click the 

Show Next  button and select Next Drawing. 

In the Drawing View window, the previous and next drawings in the onion skin 
appear in a different color to distinguish them from the drawing you are working 
on.

6. Select the Ellipse  tool from the Drawing Tools toolbar. 

7. If the Properties window is not open, select Window > Properties. The 
Properties window appears. 

8. In the Pen tab, type 20 for the Maximum Size value. When you draw with the 
centerline tools (including the Pencil, Rectangle, Ellipse, Polyline and Line) Toon 
Boom Studio uses the Maximum Size value for the width of the line.
6 
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9. In the Drawing View window, draw an ellipse roughly the shape of Mike Ant’s 
body. Don’t worry about the actual shape not being the same as the one in the 
animation. You will reshape it using the Contour Editor tool.

10. Save your animation using the File > Save command.
7
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Step 2: Reshape Mike Ant’s Body
In this step, you will use the Contour Editor tool to move the points that make up the 
ellipse you drew in step 1 and reshape Mike Ant’s body.

To reshape Mike Ant’s body:

1. From the Drawing Tools toolbar, select the Contour Editor.

2. Click the ellipse you drew in step 1. You’ll notice that a line appears down the 
center of the shape (a centerline) and that there are points on this line.

3. Use the Contour Editor to reshape the ellipse by moving the points and dragging 
the Bezier handles. (To get the Bezier handles to appear, click a point on the 
centerline.) 

The final shape should be approximately the same shape as the ant’s body shown 
in the previous drawing.

4. Save your work using the save command. Select File > Save.

After you reshape the 
ellipse, it should look 
something like this
8 
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Step 3: Draw Mike Ant with the Brush Tool
In this step, you use the Brush  tool to draw the head and then the rest of Mike Ant.

Unlike the Ellipse tool and other centerline tools (Rectangle, Polyline, Line and Pencil), 
the Brush tool creates variable-width strokes that respond to the pressure you apply 
with a digital pen and graphic tablet. 

When you draw with the Brush tool, Toon Boom Studio creates shapes that are formed 
by points that surround a zone, which is filled with color. We call the shapes created 
by the Brush tool “contour shapes”. 

Drawing with the Brush tool allows you to create distinctive lines that are more natural 
than the mechanical looking centerline shapes. However, brush strokes require more 
memory to store because they use more points to create. If you are concerned about the 
file size of your animation, consider carefully when choosing your drawing tools.

To draw Mike Ant with the Brush tool:

1. Select the Brush tool from the Drawing Tools toolbar. 

2. In the Pen tab, type 5 for the Minimum Size value. When you draw with a graphic 
tablet and pen, Toon Boom Studio uses the Minimum Size and Maximum Size 
values to determine the width of the variable-width line.

3. In the Drawing View window, use the Brush tool to draw a circle approximately 
the same shape as the Mike Ant’s head as shown in the previous drawing in the 
onion skin.

4. Using the Contour Editor tool, [Shift]-click the ant’s head drawing and the ant’s 
body. Notice the number of points in Mike Ant’s head, drawn using the Brush 
tool, and Mike Ant’s body, drawn using the Ellipse tool.
9
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When you have finished comparing the drawings deselect them by clicking anywhere 
in the Drawing View window. 

5. Using the Contour Editor tool and the curve handles, reshape the ant’s head you 
drew so that it is approximately the same shape as the ant’s head shown in the 
previous drawing in the onion skin.

6. Draw the rest of the ant. The completed drawing must fit in the run cycle, so you 
must draw Mike’s legs so that his left leg is touching the ground and his right leg 
is bent at the knee. His body should also be slightly elevated, so you might want 
to move the body up slightly. 

A brush stroke is surrounded by a 
collection of points. The outline of the 
brush stroke or painted fill is called a 
Contour. 

A line drawn with the 
Ellipse tool is defined by a 
series of centerline points.

After you reshape the head drawing it 
should look something like this.
10 
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When you finish drawing, your ant should look something like this.

You can look at the final drawing in the Drawing_Final animation project to see how 
we did it.

7. To help you with your drawing, you can use the Rotary Light Table so that you 
can get a better angle on the part of the drawing you are working on.
• To display the Rotary Light Table, hold down [Ctrl]+[Alt] when using 

Windows or [Ctrl]+[Command] when using MacOS, then use your mouse to 
freely rotate your drawing space.

• To return your drawing space to the original angle, select View > Reset 
Rotation or press [Shift] + [C].
11
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Step 4: Preview the Mike Ant Cycle
In this step, you use the Interactive Playback buttons to preview your drawing of Mike 
Ant and see how it fits into the run cycle.

To preview the Mike Ant cycle using Interactive Playback:

1. In the Exposure Sheet window, press [Shift] and select drawings 1 through 8.

2. Press Play .

All of the selected content plays in sequential order in the View window.

3. If you want the playback to repeat, select the Loop  button before you click the 
Play  button.

4. Make corrections to your Mike Ant drawing so that the transition between the 
drawings in the cycle is logical and smooth.

5. Save your animation project and you are done!
Congratulations on completing the first lesson in this tutorial.
12 
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Lesson 2: Painting
In this lesson, you will paint Mike Ant, and give him some color! 

There are two animation projects for this lesson:

• Painting_Rough
• Painting_Final

In the Painting_Rough animation project, you’ll build a color palette for Mike Ant and 
create a gradient color swatch. Then you’ll paint Mike Ant using Toon Boom Studio 
power-paint features that will speed the painting process.

To start the Painting Mike Ant lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Painting_Rough animation project in the Lesson2_Painting folder.

3. Save the animation in a location of your choice using File > Save As. 

4. Click the Play  button and watch Mike Ant run! 

You’re going to give Mike some color, as well as give him a real reason to run—
red hot flames licking his back!
13
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Step 1: Add a Color Swatch
In this step, you’ll add a color swatch to Mike Ant’s color palette.

To add a color swatch:

1. If the Properties window is not open, select Window > Properties. The 
Properties window appears. 

2. Click the Color Palette tab. The Color Palette tab appears with the default set of 
colors. 

3. From the Name drop-list, select mike. This is the Mike Ant color palette, which 
you can use to organize all of the color swatches for this buggy character.

4. You can click the Show/Hide Color Name button on the right side of the dialog 
box, just above the swatch scroll bar. This changes the display to a list of swatches 
and their names.

5. Select the belt color swatch and click the Add a Color  button. A copy of the belt 
swatch appears in the palette style and it is called New 1 by default. You will edit 
the properties of this color swatch in the next step.

This color palette 
gives you all the color 
swatches you need to 
paint your ant.

Show Color Names 
button, displays the 
swatch names.
14 
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Step 2: Create a Gradient “Flame” Swatch
In this step, you will create a gradient for the flame that is licking Mike Ant’s back. 
You’ll use the swatch you created in the previous step as the basis for the gradient.

To create a gradient: 

1. Double-click the color swatch you added in the last step. You’ll use this swatch as 
a basis for the gradient because the orange color in the swatch is similar to one of 
the gradient colors.

The color picker opens.

Gradient
15
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2. Select the Gradient option.

3. In the Gradient panel, select Radial. The colors in a radial gradient blend in a 
circular pattern.

4. Click the first marker below the Gradient bar. A square appears in the marker to 
indicate that it is editable.

5. Change the color of the first marker to yellow by dragging your mouse in the 
color swatch. We used these R, G, B values: 248, 251, 17. You can use the Color 
slider, or enter these values manually, if you want.

6. Click below the Gradient bar to add a gradient marker. The color of the marker is 
the same as the marker you had selected. Gradient markers represent the start or 
end of a transition between different colors.

7. Do one of the following: 

The look of 
your color 
picker is 
dependent 
on your 
operating 
system.
16 
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• In the Opacity field, type 60 (MacOS).
• In the Alpha field, type 150 (Windows). 

8. Change the value of the last color to red. You can use these specific values: 236, 0, 
0.

9. Close the color picker and that’s it! You have created a gradient swatch!

Step 3: Paint the Flame on Mike Ant’s Back
Now that you have created a gradient for the flame, you are ready to paint.

To paint the flame on Mike Ant’s back:

1. In the Exposure Sheet window, select the first drawing in the colorMe element. 
Mike Ant appears in the Drawing View window.

2. Set up the Drawing View window so that you have a clear view of Mike Ant.
• To turn off the grid, press [G], the default keyboard shortcut.
• To zoom in, press [X], and to zoom out press [Z].

First color Last color

Transition color
17
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• To pan the Drawing View window, press and hold [Spacebar] and use the 
Grabber tool to change the part of the window you are seeing.

3. Select the Paint  tool from the Drawing Tools toolbar.

4. From the Color Palette tab, select the gradient swatch you created for the flame.

5. Click the areas of the flame with the Paint  tool.

6. Scroll through the Mike Ant drawings and paint all of the flaming areas. Press [S] 
to advance to the next frame and press [A] to return to the previous frame.

You’ll notice that after you paint drawing 8, you will come to drawings that have 
already been painted. That’s because we repeated drawings 1 through 8 in the 
element to create a cycle. Because each cell in the Exposure Sheet window refers 
to a drawing in the animation project, when you update a drawing that is 
repeated in other frames, Toon Boom Studio updates all frames that reference that 
drawing.
18 
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Step 4: Edit the Direction of the Flame
So you’ve painted all the flames that are scorching Mike Ant on his run cycle. But do 
they look convincing? Do they look natural? Not really, if you ask me. Usually a flame 
will change color at the edges, not just in a straight line from the source.

In this step, you will use the Edit Texture  tool to change the position and length of 
the flame gradient.

To edit the flame in the painted zone:

1. Select the Edit Texture tool from the Drawing Tools toolbar. 

2. With the Edit Texture tool, click the flame gradient in one of the Mike Ant 
drawings. The gradient editor appears.

3. Grab the handles to rotate the gradient or change its length. You want to create an 
effect that looks more natural, so experiment with the Edit Texture tool.
19
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For ideas about how to create a flame effect that changes as Mike runs, check out the 
Painting_Final animation project to see how the gradient looks in each frame.

Use the handles to reshape 
the gradient.

Drag the center of the gradient editor 
and you dramatically change the look 
of the flame gradient color.
20 
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Step 5: Paint Mike Ant
In this step, you are going to get to try out the powerful auto paint features.

With auto paint, you click a zone in one drawing and Toon Boom Studio automatically 
scrolls through the rest of the drawings in the elements to check if there is a closed zone 
beneath where you clicked. If there is a closed zone, Toon Boom Studio paints the zone 
with the same color.

Another feature you need to be aware of is auto gap closing. To fill a zone with color, 
it has to be completely closed. Sometimes, when you draw with the Brush tool, you 
may not always close zones completely. When you are painting, you can set a 
threshold for line gaps so that Toon Boom Studio will paint zones regardless of the size 
of the gap that keeps them open.

To paint Mike Ant:

1. From the Tools > Auto Gap menu, select Close Large Gap. 

2. In the Exposure Sheet window, select the colorMe-1 drawing.

3. Press [X] to zoom in on the drawing so that you can see the zones clearly.

4. Select the Paint tool from the Drawing Tools toolbar.

5. In the Color Palette tab, click the skin color swatch in the mike color palette. 

6. Press [Shift]+[Option] in MacOS, or [Shift]+[Alt] in Windows, and click Mike 
Ant’s body. Your pointer changes to indicate that the Paint All tool is active. It 
may take a couple of minutes for Toon Boom Studio to paint all of the zones. 
21
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After it is done, scroll through the drawings to see that the body on all of the drawings 
are painted with the skin color swatch. You may have to manually correct some 
drawings because of where you clicked on the drawing (it might overlap other zones, 
for example).

7. Continue to use the Paint All tool until all the static areas of your drawing are 
colored.

8. When you are finished painting the big zones, you are going to have to paint the 
smaller zones one at a time. Use the names of the color swatches to identify what 
zone they belong to on Mike Ant and just click those zones with the Paint tool.

Click here with the Paint All tool and it paints the 
same spot in all of the drawings in the element.
22 
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Step 6: Export
That’s it! You’ve made Mike Ant colorful and given him real inspiration to run, a hot 
fire! Now you are ready to export your creation and share it with your friends and 
family.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button on 
the right if you want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

Your Adobe Flash movie opens automatically in a Flash player when the export 
has finished.
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Lesson 3: Lip Syncing
Lip syncing is typically considered to be the most tedious task in the animation 
process. Traditionally, before you can even begin drawing the lip positions, you have 
to analyze the voice track to determine what lip position best matches the sound at 
each frame. 

With Toon Boom Studio, the easy-to-use lip sync tool analyzes the sounds in a voice 
track and generates a lip chart based on the eight animation phonemes. In addition to 
that, Toon Boom Studio has a tool that will automatically map drawings in an element 
based on the sounds they match. These two tools together will save you time so that 
you can focus on more interesting and creative tasks.

There are two animation projects for this lesson:

• Lip_Sync_Rough
• Lip_Sync_Final

To start the Lip Sync lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Lip_Sync_Rough animation project in the Lesson3_LipSync folder.

3. Save the animation in a location of your choice using File > Save As. 

Just look at Deb Ant! So nervous? 

Looks like she’s got something to say.
24 



Chapter 2: Tutorials
Step 1: Import Deb Ant’s Voice Track
In this step, you will import a speech made by Deb while she’s at the Survivor Ant 
tribal counsel meeting. 

In Toon Boom Studio, you must import sounds into Sound elements so you must add 
a sound element first.

To import Deb Ant’s voice track:

1. Click the Add Sound Element  button at the top of the Exposure Sheet 
window. An empty sound element appears in the exposure sheet. 

2. Select Element > Rename Element and use the Rename Sound Element dialog 
box to name the element debSpeaks.

3. Right-click (Windows) or [Control]-click (MacOS) the first cell in the element and 
select Import Sound > From File from the pop-up menu. The Open dialog box 
opens.

4. Browse the Lesson3_LipSync folder and select please_dont.MP3 and click Open. 
The sound file now appears in the cell you selected. 

5. Turn-up your headphones or speakers, [Control]-click (in MacOS) or right-click 
(in Windows) the first cell in the debSpeaks element and select Play from the pop-
up menu. Listen as Deb Ant begs not to be kicked out of the tribe.

Step 2: Generate a Lip Chart for Deb Ant
In this step, you will use Toon Boom Studio to generate a lip chart that matches Deb 
Ant’s speech to a set of animation phonemes. You can use the lip chart as a reference 
as you draw the lip sync images for your characters. 

To generate a lip chart for a Deb Ant’s voice track:

1. Select the debSpeaks element and select Element > Edit Sound. The Sound 
Element Editor appears.

2. In the Sound Element panel, click the wave form of the sound track and click the 
Streamed checkbox to set up this sound for streaming. 
25
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Voice tracks are best set as streamed sounds because they begin playing before 
the entire sound is loaded and will better maintain synchronization with images 
in Adobe Flash movies.

 

3. Select the waveform in the Sound Element panel and click the Lip-Sync button. 
A progress bar appears as Toon Boom Studio analyzes the selected sound clips 
and assigns a lip sync letter to each frame.

The lip sync images on the right side of the window become active. Drag the 
frame slider in the Sound Element panel to see the lip position for each frame of 
sound.

4. Select the Enable Scrubbing option at the bottom of the Sound Element Editor. 
Scrubbing allows you to slowly play the sound forward and backward.

5. Drag the frame slider at the top of the Current Sound panel to “scrub” the sound 
track and hear for yourself the sound that Deb is making at each frame. 

Here’s the Streamed 
checkbox.
26 
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6. Click OK to close the Sound Element Editor and then save your animation 
project.

Step 3: Draw Deb Ant’s Missing Lips
In the sample Lip Sync lesson, we drew six out of seven of the lip positions for Deb Ant. 
It is up to you to draw Deb’s lip for the “D” position using the lip sync preview images.

To draw Deb Ant’s missing lips:

1. In the Exposure Sheet window, press [Ctrl] (Windows) or [Command] (MacOS) 
and drag the debSpeaks element so that it is next to the mouth column. This will 
make it easier for you to see the lip chart while you are working on Deb’s lips.

2. Right-click (Windows) or [Control]-click (MacOS) a cell in the debSpeaks element 
and select Show Lip-sync from the pop-up menu. Toon Boom Studio displays the 
phoneme assigned to each frame in the sound.

3. Click the Toggle Thumbnails button to show the lip chart.

4. Scroll down the Exposure Sheet window. At the frame in the debSpeaks element 
that is labelled D, you must double-click the equivalent cell in the mouth element 
and rename the drawing D.

This is the Toggle Thumbnails button. 
Click it and you will see preview 
images for the lip chart you computed.
27
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5. Now, with the lip sync preview image as a reference, draw Deb Ant’s lips in the D 
position. After you have finished drawing her lips, paint them using the swatches 
in the Deb Ant color palette on the Color Palette tab.

This is how Deb Ant’s lips look in the D position we drew.

Here are some tips that will help you out:

• Use the Stroke tool to create a closed zone without visible line art.
• Use the Close Gap tool to close the zone in the neck so that you can paint it.
• You can copy and paste drawings from previous cells (try the F cell) and 

modify them to suit the lip position.
• The lips must fit on Deb Ant’s head. 

You can use the onion skin to display the previous and next drawings 
and use those drawings as a reference.
You can use the Auto Light Table to display other drawings in the frame, 
including Deb. You will need to hide other elements (using the Element 
List) to display only selected elements.
You can add a drawing (like the F drawing) to the Static Light Table so 
that you can use it as a reference.

• Set up the Drawing View window so that you have a clear view of Deb Ant.
To turn off the grid, press [G], the default keyboard shortcut.

Cell labels link the contents of the cell 
to a file in your animation project.
28 
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To zoom in, press [X], and to zoom out press [Z].
To pan the Drawing View window, press and hold [Spacebar] and use 
the Grabber tool to change the part of the window you are seeing.

Step 4: Auto-Map Deb Ant’s Lips to Her 
Voice Track
In the Lip Sync Mapping dialog box, you identify each phoneme drawing for a 
character and then Toon Boom Studio automatically labels all of the cells in the 
character’s element with the appropriate label for each phoneme drawing.

To make this feature really work for you, it is best if you name your drawings with the 
seven phonemes and the closed mouth position: A, B, C, D, E, F, G, and X.

In the mouth element, we have already named all the elements with the letters of the 
seven plus one phonemes. All you have to do is map the drawings to the phonemes in 
this element, and Toon Boom Studio will do the rest of the work for you. For Deb’s lips, 
you are going to use the same drawing for the A position and the X position.

To auto-map Deb Ant’s:

1. Select the first drawing in the mouth element and press the arrow keys to scroll 
down the drawings in this element. You’ll see that the mouth positions do not 
reflect the lip chart that you generated.

2. Right-click (Windows) or [Control]-click (MacOS) the title of the debSpeaks 
element and select Modify Lip-Sync Mapping from the pop-up menu. The Lip-
Sync Mapping dialog box opens. 
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3. From the Destination element pull-down list, select mouth. This is the element 
that you are going to apply the auto-map to.

4. In the X field, type A. For Deb’s lips, you are going to use the same drawing for 
the A position and the X position.

5. Click OK. The dialog box closes. 

6. If you scroll through the mouth element now, you’ll see that all of the lip 
drawings have been mapped to the phonemes in Deb’s voice track.
30 
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Step 5: Export
It’s time to export your lip sync scene.

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button if 
you want to select an alternate location for the final file. 

5. Select Full Movie from the Export type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

Your Adobe Flash movie opens automatically in a Flash player when the export 
has finished.
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Lesson 4: Building a Multiplane 
Scene

One of the great attributes of Toon Boom Studio is the 3D scene space and the camera, 
which allows you to design multiplane moves and cinematic camera effects. 

In this lesson, you’ll create a multiplane camera move that trucks in on the action, as 
well as make that hot ant run across the stage. In the process of all this, you will also 
get to work a bit with templates.

There are two animation projects for this lesson:

• Sceneplanning_Rough
• Sceneplanning_Final

To start the Building a Multiplane Scene lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the Sceneplanning_Rough animation project in the 
Lesson4_Sceneplanning folder.

3. Save the animation in a location of your choice using File > Save As. 
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4. Play back the rough animation by selecting the Play command from the Play 
menu. Not really much to see, eh? Nothing moves, nothing happens. Go to Step 1 
to create some more interesting visual effects in this scene.

Step 1: Attach the Camera to the Peg
The first step in this lesson is to create a camera move using a peg.

The idea of the Toon Boom Studio digital peg system was inspired by traditional 2D 
cel animation. In traditional animation, cycles of animation are typically drawn in-
place. To make characters move through the cycle, animators would use peg bars, 
which would ensure that the drawings changed position gradually and precisely.

In Toon Boom Studio, you use pegs to create different types of changes over time. In 
addition to motion, you can also create scaling and rotation effects using pegs. 

Toon Boom Studio also features “cameras”, which are like traditional cameras that 
“film” the action in a scene. In Toon Boom Studio, you can combine these two features 
- cameras and pegs - to create camera moves like trucks and pans.

In Toon Boom Studio, you use one camera and can add up to two pegs in your scene. 
Using Toon Boom Studio, you can add unlimited cameras and pegs to create even 
more sophisticated scenes. 

For this step, we’ve already created the motion path that the camera will follow. All 
you have to do is attach the camera to the peg.

In the View windows, you can see the elements in your scene from the front, side and top:

• Here’s a a motion path we created with a peg

• Here’s the camera
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To attach the camera to the peg:

1. In the Timeline window, drag and drop the Camera element on top of the Peg-
camera element.

The Camera element appears indented below the Peg-camera element to indicate 
that it is attached.

2. Select Play > Play to play back the scene. Watch the camera as it follows the 
motion path of the peg.

Step 2: Add Mike Ant Template to the Scene
Templates are re-usable pieces of animation that you can share within a scene, with 
different scenes in the same animation project or with many animation projects. 
Templates can help you reduce your workload through re-use, keep the file size of 
your animations small, as well as facilitate working in a group on the same project. 

For example, you can create a template of a walk cycle and send the template file (with 
the extension TBT) to your buddy so that she can incorporate it into her animation.

You can create templates out of anything you draw or import into Toon Boom Studio 
- vector drawings, bitmaps, entire elements, groups of elements, sound or SWF files. 
With a template, you have a neat package of all the objects, which makes it easy to 
transport and manage. If you create templates from multiple elements, Toon Boom 
Studio even maintains timing (exposure) and layout information with the templates.

So why all this talk about templates? We created a template of the walk cycle of the 
painted ant, Mike. All you have to do is to drag it into the Timeline window and you 
will have added it to your scene.
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To add the Mike Ant template to the scene:

1. Select Window > Library to open the Library window. The Library window is 
your center for Toon Boom Studio content management.

2. Open the Local folder, double-click the mikeAnt.tbt file and press the Play  
button in the Library window’s preview panel. Watch as Mike Ant runs in place, 
flames scorching his back (poor Mike!). Please note that Mike only appears at 
frame 35 in the template.

3. Drag the Mike Ant template file, mikeAnt.tbt, from the Library window to the 
Timeline window. Drop it just above the first element at the top of the list. 

 

4. Save your animation project and move on to the next step, where you will make 
Mike Ant move as he runs.

From the Library window, you can use:

• The Animation folder to access 
all of the vector drawings in your 
animation.

• The Local folder to manage all of 
the templates in your current 
animation project. Local templates 
are available to the current 
animation project only.

• The Global folder to manage all of 
the templates on your system. 
Global templates are available to 
all animation projects on your 
system.

This is the preview panel of 
the Library.
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Step 3: Add a Peg and Attach Mike Ant to It
This is the first step to creating a motion path for Mike Ant. 

To add a peg and attach Mike Ant to it:

1. In the Timeline window, select the mike-color element.

2. Click the Add Parent Peg  button at the top of the Timeline window to add a 
Peg element to your animation and attach the mike-color element as its child 
element.

3. With the Peg selected, select Element > Rename Peg Element to open the Rename 
Element dialog box and change the name of the peg to Peg-mikeant. Click OK to 
confirm the name change.
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Step 4: Create Motion Path for Mike Ant
This is the biggest step in this lesson. In this step you will get to do something a bit 
more challenging - you’re going to make a motion path with the peg you just added. 
This motion path will move Mike Ant from the east to the west side of the stage as he 
moves from back to front.

You will use three Sceneplanning view windows to design and play back your motion 
effect.

To create a motion path:

1. Advance the red frame slider at the top of the Timeline window to frame 35, 
where the Mike Ant peg will start.

2. In the Timeline window, select the Peg element you just added and the Show/

Hide  button at the top of the window so that no elements are showing. Then 
click the checkboxes next to the Peg-mikeant and Camera elements so that only 
they are displayed. 

At this point, your peg is just a red circle at the center of the Top View and Side 
View windows.
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3. With the Select  tool, drag the center of the peg’s red circle to move the peg in 
the Top View and Side View windows.
• In the Side View window, move the peg so that it is just above the line that 

marks the division between north/south and place it further back in the 
scene.

• In the Top View window, place the peg against the east side of the camera 
angle.

Your Top and Side View windows will look something like these.

You may have to zoom and 
pan your windows to get the 
same views of these windows.

• To pan a window, press 
[Spacebar] and use the 
Grabber tool to move 
your view of the 
window.

• To zoom in, press [X].

• To zoom out, press [Z].

• To reset the view, press 
[Shift]+[V].

Use the Show/Hide 
checkboxes to 
display the elements
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4. Make sure you have the Peg element selected in the Timeline window and select 

Tools > Sceneplanning Tools > Motion to activate the Motion  tool.

5. With the Motion  tool in the Top View window, drag the last keyframe on the 
motion (which is on the right) path towards the west side of the camera frame and 
towards the front.

When you activate the Motion tool, two 
keyframes appear on the peg.

• The first keyframe is on the left.

• The last keyframe is on the right.
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You can enter the values for the first keyframe (frame 35) and the last keyframe (58) 
directly into the Properties window. Copy these values directly into the Offset fields 
in the Motion Point tab.

• Frame 35: 3.70 N, 41.79 E, 49.1 B
• Frame 58: 2.66 N, 25.68 W, 40.32 B

This is the last keyframe (frame 58).

The Frame field identifies the frame 
number of the selected motion point.

In the Offset fields, you can type the 
value for the selected motion point.

To advance to the next motion point, 
you can click this button.
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6. Click the Show/Hide  button to show all elements in your animation and then 
select Play > Quick Preview. This command renders your final animation so that 
you can play it back in real-time.

7. Use Playback window to watch your ant run across the stage. Be sure to turn up 
the volume on your headphones so that you can hear the sound track that plays.

Step 5: Export
Well, you have successfully created a multiplane camera move and motion path. Now 
it’s time to package your creation so that you can share it with friends and family!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click the Browse button if 
you want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.
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6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

If you had any trouble with this lesson, check out the Sceneplanning_Final animation 
project to see how we did it.
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Lesson 5: Creating Cross-Dissolves 
with Color Transform Elements

Toon Boom Studio includes a Color Transform element, which you can use to change 
the color properties of an element over time. 

In the lesson scene, a skater does some fancy tricks on a half-pipe. To accentuate his 
daring boardwork, you will use a Color Transform element to create a series of cross-
dissolves that change the transparency of the skater at different frames.

There are two animation projects for this lesson:

• ColorFX_Rough
• ColorFX_Final

You will use the ColorFX_Rough animation project to follow the steps in the lesson. 
When you have questions that you are not sure about, you can refer to ColorFX_Final 
to see how we did it. 

You will work mostly in the Timeline window to 
add and modify Color Transform elements to 
create cross-dissolves.
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To start the Creating Color Effects lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the ColorFX_Rough animation project in the Lesson5_ColorFX folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original 
to return to and use should you want to.

4. Select Play > Play to play back the rough animation. 

Notice how two images of the skater appear to overlap for several frames? Well, 
in this lesson, you are going to make the overlapping images fade-in/out to create 
a series of cross-dissolves (chain mix).

Step 1: Add the First Color Transform 
Element
To change the color of a drawing or image element over time, you attach it to a Color 
Transform element and then use this element to specify how the colors in the elements 
attached to it will change.

During the cross-dissolve you will create, two drawings will appear at the same time, 
one fades in while the other fades out. To achieve this effect, we placed each drawing 
in a separate element layer so that you can control them independently. You’ll see as 
we progress through the lesson how this enables you to create cross-dissolves.

We have put the 
drawings for the 
skater in different 
elements so that 
we can create the 
cross-dissolve 
effect.
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To add the first color transform element:

1. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

2. Enter information about the element in the New Elements dialog box:
• From the Type menu, select Color Transform Effect.
• In the Name field, type skateColor and click OK. A new element layer appears 

in the Timeline window.

3. In the element list on the left-side of the Timeline window, attach the Color 
Transform-skateColor element to the SkatePeg2 element by dragging and 
dropping it just below the peg.

 

4. Attach the sk_2 element to the Transform-skateColor element by dragging and 
dropping it on top of the effects element. 
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5. Change the start and duration of the Transform-skateColor element so that it 
matches the start and duration of the sk_2 element.
• Double-click the trackbar of the Transform-skateColor element to select it 

and drag it to frame 12.

 
• Drag the end of the trackbar so that it ends on the same frame as the sk_2 

element (frame 20).

 

6. Select File > Save to save your animation project.

Step 2: Add Keyframes and Set their Values
In the first Color Transform effect, the drawing should fade out from frame 16 to frame 
20. 

To achieve this, you must add a keyframe at frame 16. Then, at the keyframe on frame 
20, you must make the attached elements completely transparent.

With color transforms, you can chose to do an additive or a multiplicative color 
transform. 

• In additive color transformations, you select a color value that is added to all 
of the color values in an element.

• In multiplicative color transformations, you select a value (usually between 0 
and 1) and multiply this value with all of the color values in an element to 
arrive at a final value.
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Because the effect you want to create in this lesson is an even transformation of the 
alpha value (transparency) of element colors, you will create multiplicative color 
transformations. 

To make an element change from transparent to opaque to transparent, you must 
multiply the alpha values by 0, 1, and 0. When you multiply an opaque color (255 
alpha) by 0, the result is 0 which makes the color transparent.

To add a keyframe and set its value:

1. Advance the red frame at the top of the Timeline window to frame 16.

2. From the element list on the left-side of the Timeline window, select the 
Transform-skateColor element. Notice in the Properties window (Window > 
Properties) that the Color Transform tab opens.

3. In the Color Transform tab, click the Add  button to add a keyframe to the 
selected frame on the Transform-skateColor element. 
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4. Advance the red frame slider at the top of the Timeline window to frame 20. 

5. On the Color Transform tab, drag the Alpha slider in the Multiplicative section 
of the tab all the way to the left. The value should appear as 0 in the Alpha field.

6. Drag the red frame slider at the top of the window from frame 11 to 20 and watch 
as the element fades-out.

7. Select File > Save to save your animation project.

Step 3: Create the Next Color Transform 
Effect
In this step, you are going to create another color transform effect, for the next element 
in the series, that will go from transparent to opaque to transparent.

To achieve this effect, you will add a Color Transform element, set three keyframes, 
and multiply the alpha value at each keyframe by 0, 1, and 0.

To create the next color transform effect:

1. Add a Color Transform element and name it skateColor2.

2. Drag and drop the Color Transform-skateColor2 element just before the sk_3 
element in the element list. This will also attach it to the SkatePeg 2 element.

3. Attach the sk_3 element to the Color Transform-skateColor2 element.

4. Change the start frame of the Color Transform-skateColor2 element so that it 
matches the sk_3 element. Start frame: 16; End frame: 24.

A square appears in the 
Timeline to identify the 
keyframe on the trackbar.
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5. Add a keyframe to the Color Transform-skateColor2 element at frame 20. Your 
Timeline window should now look something like this:

6. In the Color Transform tab, set the keyframes to the following multiplicative 
alpha values:
• Frame 16: 0
• Frame 20: 1
• Frame 24: 0

7. Drag the red frame slider from frame 16 to 24 and watch how the first element 
fade out as the second one fades in and then out again. 

You’ll notice how the drawing in the next element appears for the last five frames. 
In the next step you’ll use the exact same color transform element to fix all of the 
other elements so that they undergo the same color transform effect.

8. Select File > Save to save your animation project.

Step 4: Clone the Color Transform Effect
All of the remaining elements, except for the last, must undergo the same color 
transform effect as you created in Step 3. Rather than duplicating your efforts, you can 
just clone the Color Transform element and attach the other elements to it. 

When you clone a Color Transform element, all of the information stored in the effect 
are duplicated so that you do not have to re-create keyframes or their values. If you 
update any one clone with new values, Toon Boom Studio will update all the other 
clones with the new values.

To clone the color transform effect follow these steps:

1. In the Timeline window, select the Color Transform-skateColor2 element.

2. Select Element > Clone Element. Toon Boom Studio creates a new element and 
names it Color Transform-skateColor2(1) and renames the original element 
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Color Transform-skateColor2(0). The new element appears at the top of the 
element list in the Timeline window.

3. Attach the new element to the SkatePeg2 element and attach the sk_4 element to 
the Color Transform-skateColor2(1) element.

4. Drag the trackbar of the color transform element so its start/end frame matches 
the element you want it to transform.

5. Repeat the previous steps for the elements sk_4 to sk_7. Make sure that as you 
attach the skater elements to the Color Transform elements that you maintain 
their layer order in the element list.

When you are done, your Timeline window should look like this.

6. Select Play > Play to play back the rough animation.

You just have to create the effect for the last element in the series and the effect 
will be complete!

7. Select File > Save to save your animation project.

Step 5: Create the Last Color Transform
Now, all that is left is the color transform for the last element that makes up the skater.

For the last color transform effect, the skater will start out transparent, become fully 
opaque and remain opaque for the rest of the scene.

To create this effect, you will add one keyframe to a Color Transform element, give the 
first keyframe a multiplicative alpha value of 0 and give the second keyframe a 
multiplicative alpha value of 1.
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This step is basically the reverse of step 2, in which you made the character start 
opaque and then end transparent.

To create the last color transform:

1. Add a Color Transform element and name it skateColor3.

2. Attach the Color Transform-skateColor3 element to the SkatePeg2 element and 
attach the sk_8 element to the Color Transform-skateColor3 element. 

3. Change the duration of the Color Transform-skateColor3 element to 9 frames 
and make the element start on frame 36.

4. Add a keyframe to frame 40 of the Color Transform-skateColor3 element.Your 
Timeline window will look something like this:

5. In the Color Transform tab, set the keyframes on the color transform element to 
the following multiplicative alpha values:
• Frame 36: 0
• Frame 40: 1

6. Select File > Save to save your animation project.

Step 6: Export
That’s it! You’ve created a pretty nifty color transform effect with one of Toon Boom 
Studio’s latest effects.

All that is left to do is to export your animation and watch it play!

To export your animation:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 
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4. Type the name of the movie in the File Name field and click Browse button if you 
want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back 
your animation.

That’s it! If you had any trouble with this lesson, check out the Color_FX_final 
animation project to see how we did it.
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Lesson 6: Creating Clipping Mask 
Effects

Toon Boom Studio includes a Clipping Effect element, which you can use to mask out 
parts of an image to reveal only those portions you want to. 

In the lesson scene, you will merge two extreme sports scenes (mountain bike guy and 
surfer guy) using a mask to reveal the second scene. While you work on this effect, we 
hope you learn some other things too!

There are two animation projects for this lesson:

• MaskFX_Rough
• MaskFX_Final

You will use the MaskFX_Rough animation project to follow the steps in the lesson. 
When you have questions that you are not sure about, you can refer to MaskFX_Final 
to see how we did it. 

To start the Creating Clipping Mask Effects lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

2. Open the MaskFX_Rough animation project in the Lesson6_MaskFX folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original 
to return to and use should you want to.

See the wave hot on the trail of 
the biker? 

That is created by a mask 
element in the shape of the 
wave, which reveals an image 
of a wave below it.
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4. Select Play > Play to play back the rough animation. 

Notice how the two scenes - the one of the biker and the other of the surfer - just 
run smack into each other? In this lesson, we’ll create a transition between these 
two scenes out of a clip in the shape of a wave, which will reveal the surf scene. 
Take a look at the final animation project, MaskFX_Final, if you want to see what 
you will do.

Step 1: Drawing the Mask
Like the masks worn by partiers at a Halloween ball, a Toon Boom Studio mask reveals 
certain visual elements while hiding others (like a Halloween mask reveals the eyes of 
the wearer, while covering most of the face).

For the first step in the creation of the mask effect, you must draw the mask that will 
reveal image(s) below it. You can only create masks from vector drawings.

We have already drawn a mask for you. The mask consists of a cycle of vector 
drawings of a wave, which will cut out an image of rolling waves beneath it. 

Take a look at the mask we drew so that you know what you can do when you create 
your next clip effect solo. 

To review the mask we created:

1. In the wave_mask element column in the Exposure Sheet window, press [Shift] 
and select frames 15 through 36.

2. Select Play > Play to play back the selection. 

Notice the wave cycle is a collection of painted vector drawings. The painted 
areas of these drawings will be like the holes in the Halloween mask that will let 
the images below it show through, assuming the shape of the mask drawings.

With the onion skin on, you can see 
the cycle of drawings that fit together 
to make the mask.
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Step 2: Building the Clipping Element
After you have created the vector drawings that will act as your mask, or in this case, 
have seen the vector drawings that will act as the mask, you are ready to add the 
Clipping Effect element.

Clipping Effect elements consist of two parts: the clip element and the mask parameter. 

• To the clip layer, you attach the elements that you want to show through the 
mask.

• To the mask parameter, you attach the vector drawing element that you want 
to use as a mask.

You will notice in our setup, that we have attached the wave_mask vector element to 
a peg, that moves the wave in the scene.

To build the mask element:

3. Click the Show/Hide checkbox next to the wave_mask element so that you can 
see it.

4. Click the Add  button at the top of the Timeline window. The New Elements 
dialog box opens.

5. From the Type drop-list, select Clipping Effect, type waveEffect in the name field 
and click OK.

• Here’s the clip layer.

• Here’s the mask parameter.

• Here’s the vector element that is attached to the 
peg.

• Here’s the clip that will “show through” the mask.
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The Timeline window will look like this:

6. Drag and drop the Peg element on top of the Mask layer. When you drag the Peg 
element, the vector element attached to it will move with it as well. You have now 
created the mask!

 

7. Drag the wave.swf Media element on top of the Clipping-waveEffect layer. The 
clip layers appear below the mask layers, but are indented out from the mask 
layers.

 

Step 3: Export
Well now that you have created your clip mask effect, you are ready to export and 
show the world the fruits of your labor!

To export your animation to SWF:

1. Select File > Export Movie. The Export dialog box opens.

2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

• Here’s the 
Clipping layer.

• Here’s the Mask 
parameter.
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4. Type the name of the movie in the File Name field and click the Browse button if 
you want to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back 
your animation.

There is an element with some text in it, which we imported from an Adobe® Illustrator 
file. To experiment more with the Mask effect, you can replace the existing mask with 
this element. Remember you will have to change the start time and exposure of this 
drawing so that it matches the duration of the transition.

Enjoy!
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Lesson 7: Retouching Drawings in 
Sceneplanning

In previous versions of Toon Boom Studio, when you animated drawings with pegs in 
Sceneplanning views, you would have to switch to a different state, called Drawing 
Mode, to retouch drawings. However, this was difficult to do in Drawing Mode 
because you were not able see how drawings would be positioned relative to each 
other as a result of Sceneplanning view animations. 

Toon Boom Studio makes it possible to retouch drawings more accurately and easily 
because you can see how drawings in different elements work together when 
animated.

There are two animation projects for this lesson:

• DrawingSceneplanning_Rough
• DrawingSceneplanning_Final

You will use the DrawingSceneplanning_Rough animation project to follow the steps 
in the lesson. When you have questions that you are not sure about, you can refer to 
DrawingSceneplanning_Final to see how we did put the final scene together. 

To start the “Drawing in Sceneplanning” lesson:

1. Download the Quick Start Tutorial files from the Toon Boom Animation website. 
You can click the Quick Start Tutorial link on the Welcome Screen to open the 
appropriate Web page.

Over the duration of the sample scene, Tania bends 
her arm. The joints at her shoulder and elbow rotate 
to create the bending motion.

In this tutorial, you will use “Drawing in 
Sceneplanning” to fix gaps that appear at the elbow 
and shoulder as a result of the bending action.
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2. Open the Lesson7_DrawingSceneplanning animation project in the 
Lesson7_DrawingSceneplanning folder.

3. Save the animation in a location of your choice using File > Save As. Saving this 
animation project to a new location will ensure that you always have the original 
to return to and use should you want to.

You are now ready to begin working on the sample scene.

Step 1: Play Back the Scene
In this first step, you will play back the rough scene to identify problems that arise from 
the rotation of the joints in the shoulder and elbow.

To play back the scene:

4. Click the Loop  button in the toolbar, then click Play .

5. Pay particular attention to the shoulder and elbow as the animation plays back. 
Press [X] to zoom in close to the image. Press [Spacebar] and drag the window to 
focus on Tania’s left side.

Click the white space to 
remove the selection 
frame.
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6. Click Stop  to stop the playback.

Step 2: Retouch the Elbow Joint
In this step, you will use the Brush tool to retouch the line art on the elbow joint.

You must select a drawing element, the frame that contains the drawing you want to 
retouch, and a drawing tool. You can draw directly in the Camera View window.

All elements that are shown in the Timeline window will appear in the Camera View 
window.

To retouch the elbow joint:

1. In the Timeline window, select the “forearm left” element.

2. Drag the red frame slider to the frame 15 in the scene. At frame 15, the gap 
between the upper arm and forearm is the greatest. Correcting the drawing at this 
frame should fix the error for the duration of the animation.

Notice the gap that appears at the shoulder 
joint.

Notice also the gap that appears in the line 
art at the elbow.

You will fix both of these problems in the 
following steps.
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3. From the Drawing Tools toolbar, select the Brush  tool. To open the Drawing 
Tools toolbar, select Window > Drawing Tools.

As soon as you activate one of the drawing tools, you enter in “Edit Drawing” 
mode.

4. Set up your drawing space so that you can work on the elbow.
• If the grid is on, you will see it in the Camera View. Press [G] to turn it off.
• To zoom in, press [X].
• To pan the window, press [Spacebar] and drag the window.
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5. In the Properties window, click the Pen tab, set your Minimum Size to 4 and the 
Maximum Size to 6.

6. From the Color Palette tab, select the “line” swatch from the “tania” palette.
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7. Use the Brush tool to connect the stroke on the forearm to the stroke on the upper 
arm.

8. Click Play  and watch the elbow as it bends. If there are any problems in your 
retouching, undo what you did and try again. Click Stop  to stop the playback 
before you try to redo your work.

Step 3: Create the Shoulder Joint
That was a pretty simple retouch example. The next fix is a little bit more sophisticated.

In the shoulder, the gap between the shoulder and the upper arm is large. In this step, 
you will practice a technique that will help you animate future jointed characters.
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To fix the hole between the torso and the upper arm, you will create a perfect circle that 
will act as the joint on which your upper arm will rotate. The circle will overlap the 
upper arm and torso so that no gaps will appear while the joint rotates. You can try this 
technique with other jointed characters you create.

To create the shoulder joint:

1. In the Timeline window, select the upper arm element and move the red frame 
slider to frame 1.

2. Zoom and pan the Camera View window so that you have a close-up view of 
Tania’s left shoulder.

3. From the Drawing Tools toolbar, select the Ellipse  tool. 

4. In the Properties window, click the Pen tab and change the Maximum Size value 
to 6.

5. Click the Color Palette tab, select a red color swatch from the Default palette. 

You will draw the circle with red, and not the color of Tania’s shirt, so that you 
can easily see the edges of the circle, which will help you position it. After you 
position the circle, you will paint it with the color of Tania’s shirt and delete the 
red line art of the circle.

6. In the Camera View window, press [Shift] to draw a perfect circle and then use 

the Select  tool to position the circle in the gap that is the shoulder.
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7. Press [Esc] to release the selected circle.

8. From the Properties window, click the Color Palette tab, select the “shirt” swatch 
from the “tania” palette.

9. From the Drawing Tools toolbar, select the Paint  tool and click inside the red 
circle to fill it with the “shirt” color.
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10. With the Select  tool, select the red line art around the circle and delete it.

11. Click Play  and watch the shoulder as it bends. If there are any problems in 
your joint, undo what you did and try again. Click Stop  to stop the playback 
before you try to redo your work.

Step 4: Retouch the Shoulder
After you have created the joint that will fill the gap between the torso and the upper 
arm, you have to add the line art that will cover the joint.

To retouch the shoulder:

1. In the Timeline window, select the “upper arm” element.

2. Drag the red frame slider to the first frame in the scene. At frame 1, the gap 
between the torso and the upper arm is its greatest. Correcting the drawing at this 
frame should fix the error for the duration of the animation.
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3. From the Drawing Tools toolbar, select the Brush  tool. 

4. From the Properties window, click the Color Palette tab, select the “line” swatch 
from the “tania” palette.

5. Use the Brush tool to draw the line art over the shoulder.

6. Click Play  and watch the shoulder. If there are any problems in your line art, 
undo what you did and try again. Click Stop  to stop the playback before you 
try to redo your work.

Step 5: Export
Export your scene and show others what you can do with the new “Drawing in 
Sceneplanning” feature.

To export your animation to SWF:

1. Select File > Export Movie. The Export dialog box opens.
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2. From the Export Format menu, select Flash Movie.

3. Select Default from the Settings menu. 

4. Type the name of the movie in the File Name field and click Browse if you want 
to select an alternate location for the final file. 

5. Select Full Movie from the Export Type panel.

6. Select the Launch Player After Export option.

7. Click OK to begin the exporting process. A progress bar appears to show you the 
progress of the export. If you want to cancel the export, click Cancel. 

After the animation is rendered, a Playback window will open and play back 
your work. Check it out and enjoy!
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